Post Reply 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Unmounting usb drive is always failing after FW downgrade !
03-19-2008, 09:19 PM (This post was last modified: 03-19-2008 09:21 PM by pcat.)
Post: #1
Unmounting usb drive is always failing after FW downgrade !
=== english below (sorry) ===

Hello everyone,

I'm experiencing a strange issue on my M740. After using for a while a 2.3.59-lemmi-02 FW which severely crashes sometimes, I decided to go back to a 2.3.15-lemmi-06 (I was using before the 2.3.15-lemmi-02 without major troubles except some minor epg problems).

After flashing (2.3.15-lemmi-06), I noticed that the USB drive wouldn't go to standby like before, when the M740 is in standby mode (with quick restart enabled).
I tried to unmount the drive from menu, but the M740 always reports that unlinking the drive fails (like if a process was using the drive preventing it from being unmounted).

I tried to flash a yet older firmware: the 2.01.00-lemmi-18. This time, I could unmount the drive from the menu the first time, however after restarting the M740, it was no longer possible and the M740 is again always failing at restart with an error saying that the drive was not properly unlinked and it goes to the lengthy fsck...

I flashed yet again the 2.3.59-lemmi-02 and on this firmware all is solved: I can mount/unmount the drive from the menu, the drive goes to sleep as the M740 go to standby, and restarting the M740 doesn't go into fsck.
*BUT* downgrading to either 2.03.15-lemmi-06 or 2.01.00-lemmi-18 raises again the unmounting issues... Even after factory reset I cannot get back a correct behavior.

As the problems started after downgrading from the 2.3.59-lemmi-02, I suspect some script or configuration parameter to be conflicting with the previous lemmi firmware, I don't know. I checked the various boot scripts (/etc/rc, /etc/rc.d, lemmi-setup etc...) and at first look it seems fine to me; but I'm not familiar enough with this device and its linux setup, so I'm likely missing something.

Any idea on what may be going wrong ? I would like to get back to the 2.3.15 without the unmount problems. I tried to find the lemmi version I had before (2.3.15-lemmi-02) but they are not archived anywhere on the web.

Thanks !

Find all posts by this user
Quote this message in a reply
Post Reply 

Forum Jump:

User(s) browsing this thread: 1 Guest(s)

Contact Us | Homepage | Return to Top | Return to Content | Lite (Archive) Mode | RSS Syndication